AccuSnap Namespace
Class
Name | Description |
---|---|
AccuSnap.Settings | |
AccuSnap.ToolState |
Defined in
- core/frontend/src/AccuSnap.ts Line 1177
AccuSnap Class
AccuSnap is an aide for snapping to interesting points on elements or decorations as the cursor moves over them.
see Using AccuSnap
extensions
Implements
Methods
Name | Description | |
---|---|---|
constructor(): AccuSnap | ||
clear(): void | Clear the current AccuSnap info. | |
enableLocate(yesNo: boolean): void | Enable locating elements. | |
enableSnap(yesNo: boolean): void | Turn AccuSnap on or off | |
getActiveSnapModes(): SnapMode[] | Get the current active SnapModes. | |
neverFlash(ids?: Id64Arg): void | Optional ids to never flash. |
Properties
Name | Type | Description | |
---|---|---|---|
areFlashed Readonly | Set<Viewport> | Views that are already flashed | |
aSnapHits | undefined | HitList<HitDetail> | Current list of hits. | |
cross Readonly | SpriteLocation | The "+" that indicates where the snap point is | |
currHit | undefined | HitDetail | Currently active hit | |
errorIcon Readonly | SpriteLocation | The icon that indicates an error | |
errorKey | undefined | string | Reason key for last error | |
explanation | undefined | string | localized message explaining why last error was generated. | |
icon Readonly | SpriteLocation | The icon that indicates what type of snap is active | |
isActive Accessor ReadOnly | boolean | Check to see whether its appropriate to generate an AccuSnap point, given the current user | |
isHot Accessor ReadOnly | boolean | Determine whether there is a current hit that is hot. | |
isLocateEnabled Accessor ReadOnly | boolean | Whether locate of elements under the cursor is enabled by the current InteractiveTool. | |
isSnapEnabled Accessor ReadOnly | boolean | Whether snapping to elements under the cursor is enabled by the current InteractiveTool. | |
isSnapEnabledByUser Accessor ReadOnly | boolean | Whether the user setting for snapping is enabled. | |
keypointDivisor Accessor ReadOnly | number | Get the current snap divisor to use to use for SnapMode.NearestKeypoint. | |
needFlash Readonly | Set<Viewport> | Views that need to be flashed |
Defined in
- core/frontend/src/AccuSnap.ts Line 180
Last Updated: 20 June, 2023