TextureMapping.Params Class
Parameters describing how a RenderTexture's image is mapped to a surface.
Methods
Name | Description | |
---|---|---|
constructor(props?: TextureMapping.ParamProps): TextureMapping.Params |
Properties
Name | Type | Description | |
---|---|---|---|
mode | TextureMapping.Mode | The mode by which to map the image to a surface. | |
textureMatrix | TextureMapping.Trans2x3 | The matrix used to map the image to a surface. | |
weight | number | The ratio in [0, 1] with which to mix the color sampled from the texture with the element's color. |
Defined in
- core/common/src/TextureMapping.ts Line 118
Last Updated: 20 June, 2023