TextureMapping.Trans2x3 Class
A 2x3 matrix for mapping a texture image to a surface.
Methods
Name | Description | |
---|---|---|
constructor(m00: number = 1, m01: number = 0, originX: number = 0, m10: number = 0, m11: number = 1, originY: number = 0): TextureMapping.Trans2x3 | Construct from the two rows of the matrix: |
Properties
Name | Type | Description | |
---|---|---|---|
identity StaticReadonly | TextureMapping.Trans2x3 | An immutable 2x3 identity matrix. | |
transform Readonly | Transform | The 3x4 transform produced from the 2x3 matrix. |
Defined in
Last Updated: 20 June, 2023