CompressedId64Set.decompressSet Function
Decompress the compact string representation of an Id64Set into an Id64Set.
decompressSet(compressedIds: string, out?: Id64Set): Id64Set
throws Error if compressedIds
is not a well-formed CompressedId64Set.
see CompressedId64Set.compressSet to perform the inverse operation.
see CompressedId64Set.decompressArray to decompress as an Id64Array instead.
see CompressedId64Set.iterable to efficiently iterate the Ids.
Parameter | Type | Description |
---|---|---|
compressedIds | string | The compact string representation. |
out | Id64Set | If supplied, the Ids will be inserted into this set rather than allocating and returning a new set. |
Returns - Id64Set
The set containing the decompressed Ids.
Defined in
Last Updated: 20 June, 2023