CompressedId64Set.decompressArray Function
Decompress the compact string representation of an Id64Set into an Id64Array.
decompressArray(compressedIds: string, out?: Id64Array): Id64Array
throws Error if compressedIds
is not a well-formed CompressedId64Set.
note The Ids are decompressed and appended to the array in ascending order based on their 64-bit numerical values.
see CompressedId64Set.compressArray to perform the inverse operation.
see CompressedId64Set.decompressSet to decompress as an Id64Set instead.
see CompressedId64Set.iterable to efficiently iterate the Ids.
Parameter | Type | Description |
---|---|---|
compressedIds | string | The compact string representation. |
out | Id64Array | If supplied, the Ids will be appended to this array rather than allocating and returning a new array. |
Returns - Id64Array
The array containing the decompressed Ids.
Defined in
Last Updated: 20 June, 2023