DefinitionGroupGroupsDefinitions Class
Relates a DefinitionGroup to its DefinitionElement members.
note The associated ECClass was added to the BisCore schema in version 1.0.10
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ElementGroupsMembersProps, iModel: IModelDb): DefinitionGroupGroupsDefinitions |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | ElementGroupsMembers | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | ElementGroupsMembers | Delete this Relationship from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | ElementGroupsMembers | Call a function for each property of this Entity. |
getReferenceIds(): Set<string> | ElementGroupsMembers | Get the Ids of this element's references. |
insert(): string | ElementGroupsMembers | Insert this Relationship into the iModel. |
update(): void | ElementGroupsMembers | Update this Relationship in the iModel. |
create<T extends ElementRefersToElements<T>>(iModel: IModelDb, sourceId: string, targetId: string, memberPriority: number = 0): T Static | ElementGroupsMembers | Create an instance of the Relationship. |
getInstance<T extends Relationship<T>>(iModel: IModelDb, criteria: string | SourceAndTarget): T Static | ElementGroupsMembers | |
insert<T extends ElementRefersToElements<T>>(iModel: IModelDb, sourceId: string, targetId: string): string Static | ElementGroupsMembers | Insert a new instance of the Relationship. |
is(otherClass: undefined): boolean Static | ElementGroupsMembers | return whether this Entity class is a subclass of another Entity class |
onDeletedDependency(_props: RelationshipProps, _iModel: IModelDb): void Static | ElementGroupsMembers | Callback invoked by saveChanges on an ElementDrivesElement relationship when the relationship instance has been deleted. |
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void Static | ElementGroupsMembers | Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | ElementGroupsMembers | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | ElementGroupsMembers | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | ElementGroupsMembers | The name of the BIS class associated with this class. |
id | string | ElementGroupsMembers | The Id of this Entity. |
iModel | IModelDb | ElementGroupsMembers | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | ElementGroupsMembers | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
memberPriority | number | ElementGroupsMembers | |
schema Static | undefined | ElementGroupsMembers | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | ElementGroupsMembers | The name of the BIS Schema that defines this class |
sourceId Readonly | string | ElementGroupsMembers | |
targetId Readonly | string | ElementGroupsMembers |
Defined in
- backend/src/Relationship.ts Line 167
Last Updated: 20 June, 2023