SpatialLocationModel Class
A container for persisting spatial location elements.
Extends
Methods
Name | Description | |
---|---|---|
insert(iModelDb: IModelDb, parentSubjectId: string, name: string, isPlanProjection?: boolean): string Static | Insert a SpatialLocationPartition and a SpatialLocationModel that sub-models it. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | SpatialModel | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | SpatialModel | Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | SpatialModel | Call a function for each property of this Entity. |
getJsonProperty(name: string): any | SpatialModel | |
getReferenceIds(): Set<string> | SpatialModel | Get the Ids of this element's references. |
getUserProperties(namespace: string): any | SpatialModel | Get a set of JSON user properties by namespace |
insert(): string | SpatialModel | Insert this Model in the iModel |
queryExtents(): Range3d | SpatialModel | Query for the union of the extents of the elements contained by this model. |
queryRange(): Promise<Range3d> | SpatialModel | Query for the union of the extents of all elements contained within this model. |
removeUserProperties(nameSpace: string): void | SpatialModel | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void | SpatialModel | |
setUserProperties(nameSpace: string, value: any): void | SpatialModel | Change a set of user JSON properties of this Element by namespace. |
update(): void | SpatialModel | Update this Model in the iModel. |
is(otherClass: undefined): boolean Static | SpatialModel | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnModelIdArg): void ProtectedStatic | SpatialModel | Called before a Model is deleted. |
onDeleteElement(_arg: OnElementInModelIdArg): void ProtectedStatic | SpatialModel | Called when an Element in an instance of a Model of this class is about to be deleted. |
onDeleted(_arg: OnModelIdArg): void ProtectedStatic | SpatialModel | Called after a Model was deleted. |
onDeletedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | SpatialModel | Called after an Element in an instance of a Model of this class has been deleted. |
onInsert(arg: OnModelPropsArg): void ProtectedStatic | SpatialModel | Called before a new Model is inserted. |
onInsertElement(_arg: OnElementInModelPropsArg): void ProtectedStatic | SpatialModel | Called before a prospective Element is to be inserted into an instance of a Model of this class. |
onInserted(_arg: OnModelIdArg): void ProtectedStatic | SpatialModel | Called after a new Model is inserted. |
onInsertedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | SpatialModel | Called after an Element has been inserted into an instance of a Model of this class. |
onUpdate(arg: OnModelPropsArg): void ProtectedStatic | SpatialModel | Called before a Model is updated. |
onUpdateElement(_arg: OnElementInModelPropsArg): void ProtectedStatic | SpatialModel | Called when an Element in an instance of a Model of this class is about to be updated. |
onUpdated(_arg: OnModelIdArg): void ProtectedStatic | SpatialModel | Called after a Model is updated. |
onUpdatedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | SpatialModel | Called after an Element in an instance of a Model of this class has been updated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | SpatialModel | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | SpatialModel | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | SpatialModel | The name of the BIS class associated with this class. |
geometryGuid | undefined | string | SpatialModel | |
id | string | SpatialModel | The Id of this Entity. |
iModel | IModelDb | SpatialModel | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | SpatialModel | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isNotSpatiallyLocated Readonly | boolean | SpatialModel | If true, then the elements in this GeometricModel3d are not in real-world coordinates and will not be in the spatial index. |
isPlanProjection Readonly | boolean | SpatialModel | If true, then the elements in this GeometricModel3d are expected to be in an XY plane. |
isPrivate | boolean | SpatialModel | |
isSpatiallyLocated Accessor ReadOnly | boolean | SpatialModel | If true, then the elements in this GeometricModel3d are in real-world coordinates and will be in the spatial index. |
isTemplate | boolean | SpatialModel | |
jsonProperties Readonly | { T } | SpatialModel | |
modeledElement Readonly | RelatedElement | SpatialModel | |
name Readonly | string | SpatialModel | |
parentModel Readonly | string | SpatialModel | |
schema Static | undefined | SpatialModel | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | SpatialModel | The name of the BIS Schema that defines this class |
Defined in
- backend/src/Model.ts Line 377
Last Updated: 20 June, 2023