tryGetModelProps Method
Get the ModelProps with the specified identifier.
tryGetModelProps<T extends ModelProps>(id: string): undefined | T
throws IModelError if the model cannot be loaded.
note Useful for cases when a model may or may not exist and throwing an Error
would be overkill.
see IModelDb.Models.getModelProps
Parameter | Type | Description |
---|---|---|
id | string |
Returns - undefined | T
The ModelProps or undefined
if the model is not found.
Defined in
- backend/src/IModelDb.ts Line 1360
Last Updated: 20 June, 2023