TableDataProvider Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
TableDataProvider provides data to the Table. It also provides support for data Sorting & Filtering.
Methods
Name | Description | |
---|---|---|
applyFilterDescriptors(filterDescriptors: CompositeFilterDescriptorCollection): Promise<void> Optional | Apply a filter descriptor collection | |
getColumns(): Promise<ColumnDescription[]> | Retrieves the column descriptions | |
getDistinctValues(columnKey: string, maximumValueCount?: number): Promise<DistinctValueCollection> Optional | Gets distinct values in a column | |
getPropertyDisplayValueExpression(property: string): string Optional | Gets property display value expression | |
getRow(rowIndex: number, unfiltered?: boolean): Promise<RowItem> | Retrieves a specific row by index | |
getRowsCount(): Promise<number> | Retrieves the row count | |
sort(columnIndex: number, sortDirection: SortDirection): Promise<void> | Sorts the rows based on the value in a specific column |
Properties
Name | Type | Description | |
---|---|---|---|
onColumnsChanged | TableDataChangeEvent | Event emitted by the data provider when column data changes | |
onRowsChanged | TableDataChangeEvent | Event emitted by the data provider when row data changes |
Defined in
Last Updated: 20 June, 2023