CompositeFilterDescriptorCollection Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Collection of FilterDescriptor objects composed together by a logical operator.
Methods
Name | Description | |
---|---|---|
add(item: FilterDescriptor): void | Adds a filter descriptor to the collection | |
clear(): void | Clears the filter descriptor. | |
evaluateRow(row: RowItem): boolean | Evaluates a row for filtering | |
getColumnFilterDescriptor(columnKey: string): undefined | ColumnFilterDescriptor | Gets the filter for a particular column | |
getFilterExpression(): string | Returns filter as ECExpression. | |
isColumnFilterActive(columnKey: string): boolean | Determines if a filter is active for a particular column |
Properties
Name | Type | Description | |
---|---|---|---|
count | number | Gets the number of filter descriptors in the collection | |
logicalOperator | FilterCompositionLogicalOperator | Gets and sets the logical operator. |
Defined in
Last Updated: 20 June, 2023