FilterDescriptor Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
A filtering abstraction that knows how to create predicate filtering expression.
Methods
Name | Description | |
---|---|---|
clear(): void | Clears the filter descriptor and sets it to inactive. | |
evaluateRow(row: RowItem): boolean | Evaluates a row for filtering. | |
getFilterExpression(): string | Returns filter as ECExpression. | |
isFilterForColumn(columnKey: string): boolean | Determines if this filter is for a particular column. |
Properties
Name | Type | Description | |
---|---|---|---|
isActive | boolean | Gets a value indicating whether this filter is active. |
Defined in
Last Updated: 20 June, 2023