ColumnFilterDescriptor Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Represents a column filter descriptor associated with a specific column.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
clear(): void | FilterDescriptor | Clears the filter descriptor and sets it to inactive. |
evaluateRow(row: RowItem): boolean | FilterDescriptor | Evaluates a row for filtering. |
getFilterExpression(): string | FilterDescriptor | Returns filter as ECExpression. |
isFilterForColumn(columnKey: string): boolean | FilterDescriptor | Determines if this filter is for a particular column. |
Properties
Name | Type | Description | |
---|---|---|---|
distinctFilter | DistinctValuesFilterDescriptor | Gets the Distinct Values filter descriptor. | |
fieldFilter | FieldFilterDescriptor | Gets the Field filter descriptor. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
isActive | boolean | FilterDescriptor | Gets a value indicating whether this filter is active. |
Defined in
Last Updated: 20 June, 2023