FieldFilterDescriptor Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Represents the field filter descriptor of a column filter descriptor.
Extends
Methods
Name |
Description |
|
addFieldValue(fieldValue: any, operator: FilterOperator, isCaseSensitive?: boolean): void |
Adds the field value. |
|
removeFieldValue(fieldValue: any, operator: FilterOperator): boolean |
Removes the field value. |
|
tryFindDescriptor(fieldValue: any, operator: FilterOperator): undefined | FilterDescriptor |
Tries to find descriptor. |
|
Inherited methods
Properties
Inherited properties
Name |
Type |
Inherited from |
Description |
isActive |
boolean |
FilterDescriptor |
Gets a value indicating whether this filter is active. |
Defined in
Last Updated:
20 June, 2023