PropertyEditorManager Class
Manages Property Editors. Property Editors are registered with and created by the manager.
Methods
Name | Description | |
---|---|---|
constructor(): PropertyEditorManager | ||
createEditor(editType: string, editorName?: string, dataControllerName?: string): PropertyEditorBase Static | ||
hasCustomEditor(editType: string, editorName: string): boolean Static | ||
registerDataController(controllerName: string, controller: () => DataControllerBase): void Static | ||
registerEditor(editType: string, editor: () => PropertyEditorBase, editorName?: string): void Static |
Defined in
Last Updated: 20 June, 2023