IPropertyValueRenderer Interface
Custom property value renderer interface
Implemented by
- ArrayPropertyValueRenderer
- DoublePropertyValueRenderer
- MergedPropertyValueRenderer
- NavigationPropertyValueRenderer
- PrimitivePropertyValueRenderer
- StructPropertyValueRenderer
- UrlPropertyValueRenderer
Methods
Name | Description | |
---|---|---|
canRender(record: PropertyRecord, context?: PropertyValueRendererContext): boolean | Checks if the renderer can handle given property | |
render(record: PropertyRecord, context?: PropertyValueRendererContext): ReactNode | Method that returns a JSX representation of PropertyRecord |
Defined in
Last Updated: 20 June, 2023