PanViewTool Class
The tool that performs a Pan view operation
Extends
Methods
Name | Description | |
---|---|---|
constructor(vp: ScreenViewport | undefined, oneShot: boolean = false, isDraggingRequired: boolean = false): PanViewTool | ||
onReinitialize(): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyToolSettingPropertyChange(_updatedValue: ToolSettingsPropertySyncItem): boolean | InteractiveTool | Used to receive property changes from UI. |
beginDynamicUpdate(): void | ViewTool | |
beginDynamics(): void | InteractiveTool | Call to initialize dynamics mode. |
changeLocateState(enableLocate: boolean, enableSnap?: false | true, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | InteractiveTool | Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled. |
changeViewport(vp?: ScreenViewport): void | ViewManip | |
decorate(context: DecorateContext): void | ViewManip | |
decorateSuspended(_context: DecorateContext): void | InteractiveTool | Called to allow a suspended tool to display non-element decorations in overlay mode. |
endDynamicUpdate(): void | ViewTool | |
endDynamics(): void | InteractiveTool | Call to terminate dynamics mode. |
enforceZUp(pivotPoint: Point3d): boolean | ViewManip | |
exitTool(): void | ViewTool | Do not override. |
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> | InteractiveTool | Invoked to allow tools to filter which elements can be located. |
getCurrentButtonEvent(ev: BeButtonEvent): void | InteractiveTool | Fill the supplied button event from the current cursor location. |
getDecorationGeometry(_hit: HitDetail): GeometryStreamProps | undefined | InteractiveTool | Called to allow snapping to pickable decoration geometry. |
getToolTip(_hit: HitDetail): Promise<HTMLElement | string> | InteractiveTool | Invoked before the locate tooltip is displayed to retrieve the information about the located element. |
initLocateElements(enableLocate: boolean = true, enableSnap?: false | true, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | InteractiveTool | Helper method for tools that need to locate existing elements. |
isCompatibleViewport(_vp: ScreenViewport, _isSelectedViewChange: boolean): boolean | InteractiveTool | |
isPointVisible(testPt: Point3d): boolean | ViewManip | Determine whether the supplied point is visible in this Viewport. |
isValidLocation(_ev: BeButtonEvent, _isButtonEvent: boolean): boolean | InteractiveTool | |
lensAngleMatches(angle: Angle, tolerance: number): boolean | ViewManip | |
onCleanup(): void | ViewManip | |
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> | ViewManip | |
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | ViewManip | |
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void | InteractiveTool | Called to allow Tool to display dynamic elements. |
onInstall(): boolean | InteractiveTool | Override to execute additional logic when tool is installed. |
onKeyTransition(wentDown: boolean, keyEvent: KeyboardEvent): Promise<EventHandled> | ViewManip | |
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the middle mouse button is pressed. |
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the middle mouse button is released. |
onModifierKeyTransition(wentDown: boolean, modifier: BeModifierKeys, event: KeyboardEvent): Promise<EventHandled> | ViewManip | |
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> | ViewManip | |
onMouseMotion(ev: BeButtonEvent): Promise<void> | ViewManip | |
onMouseStartDrag(ev: BeButtonEvent): Promise<EventHandled> | ViewManip | |
onMouseWheel(inputEv: BeWheelEvent): Promise<EventHandled> | ViewManip | |
onPostInstall(): void | ViewManip | |
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the reset button is pressed. |
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | ViewTool | |
onSelectedViewportChanged(_previous: ScreenViewport | undefined, _current: ScreenViewport | undefined): void | InteractiveTool | Called when active view changes. |
onSuspend(): void | InteractiveTool | Notification of a ViewTool or InputCollector starting and this tool is being suspended. |
onTouchCancel(ev: BeTouchEvent): Promise<void> | ViewManip | |
onTouchComplete(ev: BeTouchEvent): Promise<void> | ViewManip | |
onTouchEnd(ev: BeTouchEvent): Promise<void> | ViewManip | |
onTouchMove(ev: BeTouchEvent): Promise<void> | ViewManip | |
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> | ViewManip | |
onTouchStart(ev: BeTouchEvent): Promise<void> | ViewManip | |
onTouchTap(ev: BeTouchEvent): Promise<EventHandled> | ViewManip | |
onUnsuspend(): void | InteractiveTool | Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended. |
parseAndRun(..._args: string[]): boolean | Tool | Run this instance of a tool using a series of string arguments. |
processFirstPoint(ev: BeButtonEvent): boolean | ViewManip | |
processPoint(ev: BeButtonEvent, inDynamics: boolean): boolean | ViewManip | |
provideToolAssistance(mainInstrKey: string, additionalInstr?: ToolAssistanceInstruction[]): void | ViewManip | |
run(..._args: any[]): boolean | ViewTool | |
setCameraLensAngle(lensAngle: Angle, retainEyePoint: boolean): ViewStatus | ViewManip | |
setTargetCenterWorld(pt: Point3d, lockTarget: boolean, saveTarget: boolean): void | ViewManip | Set the center of rotation for rotate handle. |
supplyToolSettingsProperties(): ToolSettingsPropertyRecord[] | undefined | InteractiveTool | Used to supply list of properties that can be used to generate ToolSettings. |
syncToolSettingsProperties(syncData: ToolSettingsPropertySyncItem[]): void | InteractiveTool | Called by tool to synchronize the UI with property changes made by tool. |
testDecorationHit(_id: string): boolean | InteractiveTool | Called to support operations on pickable decorations, like snapping. |
updateTargetCenter(): void | ViewManip | |
fitView(viewport: ScreenViewport, animateFrustumChange: boolean, marginPercent?: MarginPercent): void Static | ViewManip | |
getDefaultTargetPointWorld(vp: Viewport): Point3d Static | ViewManip | |
getFocusPlaneNpc(vp: Viewport): number Static | ViewManip | |
register(namespace?: I18NNamespace, i18n?: I18N): void Static | Tool | Register this Tool class with the ToolRegistry. |
showPrompt(prompt: string): void Static | ViewTool | |
translate(val: string): any Static | ViewTool | |
zoomToAlwaysDrawnExclusive(viewport: ScreenViewport, animateFrustumChange: boolean, marginPercent?: MarginPercent): Promise<boolean> Static | ViewManip |
Properties
Name | Type | Description | |
---|---|---|---|
iconSpec Static | string | ||
toolId Static | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor ReadOnly | string | Tool | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | Tool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, Tool.flyover is returned. |
englishKeyin Accessor StaticReadOnly | string | Tool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | Tool | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | Tool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, Tool.keyin is returned. |
frustumValid | boolean | ViewManip | |
handleMask ConstructorProperty | number | ViewManip | |
hidden Static | boolean | Tool | If true, this Tool will not appear in the list from ToolRegistry.getToolList. |
i18n Static | I18N | Tool | The internationalization services instance used to translate strings from the namespace. |
iconSpec Accessor ReadOnly | string | Tool | Get the iconSpec from this Tool's class. |
inDynamicUpdate | boolean | ViewTool | |
inHandleModify | boolean | ViewManip | |
isDragging | boolean | ViewManip | |
isDraggingRequired ConstructorProperty | boolean | ViewManip | |
isDynamicsStarted Accessor ReadOnly | boolean | InteractiveTool | Call to find out if dynamics are currently active. |
isZUp Accessor ReadOnly | boolean | ViewManip | |
keyin Accessor ReadOnly | string | Tool | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | Tool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
maxArgs Accessor StaticReadOnly | number | undefined | Tool | The maximum number of arguments allowed by Tool.parseAndRun, or undefined if there is no maximum. If subclasses override Tool.parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor StaticReadOnly | number | Tool | The minimum number of arguments allowed by Tool.parseAndRun. If subclasses override Tool.parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static | I18NNamespace | Tool | The I18NNamespace that provides localized strings for this Tool. |
nPts | number | ViewManip | |
oneShot ConstructorProperty | boolean | ViewManip | |
receivedDownEvent | boolean | InteractiveTool | Used to avoid sending tools up events for which they did not receive the down event. |
targetCenterLocked | boolean | ViewManip | |
targetCenterValid | boolean | ViewManip | |
targetCenterWorld | Point3d | ViewManip | |
toolId Accessor ReadOnly | string | Tool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
viewport ConstructorProperty | undefined | ScreenViewport | ViewTool |
Defined in
- core/frontend/src/tools/ViewTool.ts Line 2409
Last Updated: 13 June, 2024