BeWheelEvent Class
A BeButtonEvent generated by movement of a mouse wheel.
note wheel events include mouse location.
Extends
Implements
Methods
Inherited methods
Properties
Name |
Type |
Description |
|
time |
number |
|
|
wheelDelta |
number |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
button |
BeButton |
BeButtonEvent |
The mouse button that created this event. |
coordsFrom |
CoordSource |
BeButtonEvent |
How the coordinate values were generated (either from an action by the user or from a program.) |
inputSource |
InputSource |
BeButtonEvent |
Whether this event came from a pointing device (e.g. |
isAltKey Accessor ReadOnly |
boolean |
BeButtonEvent |
Determine whether the alt key was pressed |
isControlKey Accessor ReadOnly |
boolean |
BeButtonEvent |
Determine whether the control key was pressed |
isDoubleClick |
boolean |
BeButtonEvent |
If true, this is the second down in a rapid double-click of the same button. |
isDown |
boolean |
BeButtonEvent |
If true, this event was generated from a mouse-down transition, false from a button-up transition. |
isDragging |
boolean |
BeButtonEvent |
If true, this event was created by pressing, holding, and then moving a mouse button. |
isShiftKey Accessor ReadOnly |
boolean |
BeButtonEvent |
Determine whether the shift key was pressed |
isValid Accessor ReadOnly |
boolean |
BeButtonEvent |
Determine whether this BeButtonEvent has valid data. |
keyModifiers |
BeModifierKeys |
BeButtonEvent |
The keyboard modifiers that were pressed when the event was generated. |
point Accessor |
Point3d |
BeButtonEvent |
The point for this event, in world coordinates. |
rawPoint Accessor |
Point3d |
BeButtonEvent |
The raw (unadjusted) point for this event, in world coordinates. |
viewPoint Accessor |
Point3d |
BeButtonEvent |
The point, in screen coordinates for this event. |
viewport |
undefined | ScreenViewport |
BeButtonEvent |
The ScreenViewport from which this BeButtonEvent was generated. |
Defined in
Last Updated:
13 June, 2024