WebGLRenderCompatibilityInfo Interface
Describes the level of compatibility of a client device/browser with the iTwin.js rendering system.
Properties
Name | Type | Description | |
---|---|---|---|
undefined | string | If WebGL context creation failed, an error message supplied by the browser. | ||
createdContext | undefined | WebGLContext | The WebGL context created by the browser and used to generate the compatibility report. | |
driverBugs | GraphicsDriverBugs | Known bugs associated with the client's graphics driver for which iTwin.js can apply workarounds. | |
missingOptionalFeatures | WebGLFeature[] | Optional features unsupported by this client that would provide improved performance or quality if present. | |
missingRequiredFeatures | WebGLFeature[] | Features that are required by the rendering system but not supported by the client. | |
status | WebGLRenderCompatibilityStatus | Describes the overall status of rendering compatibility. | |
unmaskedRenderer | undefined | string | The renderer string reported by this client's graphics driver. | |
unmaskedVendor | undefined | string | The vendor string reported by this client's graphics driver. | |
userAgent | string | The user agent as reported by the browser. | |
usingIntegratedGraphics | undefined | boolean | If true, there is a likelihood that integrated graphics are being used. |
Defined in
- RenderCompatibility.ts Line 104
Last Updated: 20 June, 2023