WebGLFeature Enumeration
Enumerates the required and optional WebGL features used by the RenderSystem.
Members
Name |
Value |
Description |
MrtPick |
"mrt pick" |
This feature allows picking to occur more efficiently, using 1 pass instead of 3. |
Instancing |
"instancing" |
This feature allows instancing of repeated geometry, which can reduce memory consumption. |
ShadowMaps |
"shadow maps" |
Indicates that shadow maps are supported. Without this feature, shadows cannot be displayed. |
AntiAliasing |
"anti-aliasing" |
This feature allows the renderer to smooth curved lines. |
DepthTexture |
"depth texture" |
This feature allows for the display of non-3D classification data and solar shadows. |
FragDepth |
"fragment depth" |
This feature allows a logarithmic depth buffer to be used. Without this feature, z-fighting will be much more likely to occur. |
FloatRendering |
"float rendering" |
This feature allows transparency to achieve the optimal quality. Without this feature, overlapping transparent geometry will "wash out" more easily. |
MrtTransparency |
"mrt transparency" |
This feature allows transparent geometry to be rendered more efficiently, using 1 pass instead of 2. |
UintElementIndex |
"uint element index" |
This feature ensures large meshes (with more than 21,845 triangles) can be rendered. |
StandardDerivatives |
"standard derivatives" |
This feature allows the renderer to achieve accurate contour lines for isoline and stepped delimiter modes of thematic display. |
MinimalTextureUnits |
"minimal texture units" |
This feature indicates that the system has enough texture units available for the shaders to run properly. |
Defined in
Last Updated:
20 June, 2023