WebGLRenderCompatibilityStatus Enumeration
An enumeration that describes a general "compatibility rating" based on the contents of a WebGLRenderCompatibilityInfo.
Members
Name | Value | Description |
---|---|---|
AllOkay | 0 | Signifies that everything is ideal: context created successfully, all required and optional features are available, and browser did not signal a major performance caveat. |
MissingOptionalFeatures | 1 | Signifies that the base requirements of compatibility are met but at least some optional features are missing. Consult the contents of WebGLRenderCompatibilityInfo.missingOptionalFeatures. |
MajorPerformanceCaveat | 2 | Signifies that the base requirements of compatibility are met but WebGL reported a major performance caveat. The browser has likely fallen back to software rendering due to lack of a usable GPU. Consult WebGLRenderCompatibilityInfo.contextErrorMessage for a possible description of what went wrong. There could also be some missing optional features; consult the contents of WebGLRenderCompatibilityInfo.missingOptionalFeatures. |
MissingRequiredFeatures | 3 | Signifies that the base requirements of compatibility are not met; rendering cannot occur. Consult the contents of WebGLRenderCompatibilityInfo.missingRequiredFeatures. |
CannotCreateContext | 4 | Signifies an inability to create either a canvas or a WebGL rendering context; rendering cannot occur. Consult WebGLRenderCompatibilityInfo.contextErrorMessage for a possible description of what went wrong. |
Defined in
- RenderCompatibility.ts Line 47
Last Updated: 20 June, 2023