NavigationPropertyTargetEditor Class
Beta
Component that renders navigation property target selector for navigation property value editing.
Note: Should be used inside navigationPropertyEditorContext.
Extends
- PureComponent<PropertyEditorProps>
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: PropertyEditorProps | Readonly<PropertyEditorProps>): NavigationPropertyTargetEditor | ||
constructor(props: PropertyEditorProps, context: any): NavigationPropertyTargetEditor | Deprecated | |
getPropertyValue(): Promise<undefined | PropertyValue> |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus Accessor ReadOnly | boolean | ||
htmlElement Accessor ReadOnly | | HTMLDivElement |
Defined in
Last Updated: 20 June, 2023