StyleOverride Interface
Deprecated in 3.x. Use ExtendedDataRule instead. See extended data usage page for more details.
Style override rules allow customizing display style of specific types of ECInstances.
see Style override reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
backColor | undefined | string | Background color that should be used for node. | |
condition | undefined | string | Defines a condition for the rule, which needs to be met in order to execute it. | |
fontStyle | undefined | string | Font style that should be used for node. | |
foreColor | undefined | string | Foreground color that should be used for node. | |
ruleType | "StyleOverride" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 20 June, 2023