ExtendedDataRule Interface
Extended data rule is used to inject some arbitrary data into presentation data objects (nodes, content records).
see Extended data rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | undefined | string | Defines a condition which needs to be met in order for the rule to be used. | |
items | { T } | A map of ECExpressions whose | |
ruleType | "ExtendedData" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 20 June, 2023