SelectedNodeInstancesSpecification Interface
Returns content for selected (input) instances.
see Selected node instances specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
acceptableClassNames | undefined | string[] | Specifies a list of class names which the input instances have to match for the specification to be used. | |
acceptablePolymorphically | undefined | boolean | Specifies whether derived classes of SelectedNodeInstancesSpecification.acceptableClassNames should be included in the content. | |
acceptableSchemaName | undefined | string | Specifies ECSchema name which the input instances have to match for the specification to be used. | |
specType | "SelectedNodeInstances" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties | undefined | CalculatedPropertiesSpecification[] | ContentSpecificationBase | Specifications of calculated properties whose values are |
onlyIfNotHandled | undefined | boolean | ContentSpecificationBase | Specifies whether this specification should be ignored if another specification was handled before as |
priority | undefined | number | ContentSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is handled |
propertyCategories | undefined | PropertyCategorySpecification[] | ContentSpecificationBase | Specifications for custom categories. |
propertyOverrides | undefined | PropertySpecification[] | ContentSpecificationBase | Specifications for various property overrides that allow customizing property display. |
relatedInstances | undefined | RelatedInstanceSpecification[] | ContentSpecificationBase | Specifications of related instances that can be used when creating the content. |
relatedProperties | undefined | RelatedPropertiesSpecification[] | ContentSpecificationBase | Specifications of related properties which are |
showImages | undefined | boolean | ContentSpecificationBase | Should image IDs be calculated for the returned instances. |
Defined in
- presentation/common/src/presentation-common/rules/content/SelectedNodeInstancesSpecification.ts Line 17
Last Updated: 20 June, 2023