LabelOverride Interface
Deprecated in 3.x. Use InstanceLabelOverride rule instead.
Label override rules provide advanced ways to override instance labels and descriptions in exchange of some performance penalty.
see Label override reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | undefined | string | Defines a condition for the rule, which needs to be met in order to execute it. | |
description | undefined | string | An expression whose result becomes the description. | |
label | undefined | string | An expression whose result becomes the label. | |
ruleType | "LabelOverride" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 20 June, 2023