ContentRelatedInstancesSpecification Interface
Returns content for instances related to the selected (input) instances.
see Content related instances specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
instanceFilter | undefined | string | Specifies an ECExpression for filtering instances | |
relationshipPaths | RepeatableRelationshipPathSpecification[] | Specifies a chain of relationship path specifications that | |
specType | "ContentRelatedInstances" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties | undefined | CalculatedPropertiesSpecification[] | ContentSpecificationBase | Specifications of calculated properties whose values are |
onlyIfNotHandled | undefined | boolean | ContentSpecificationBase | Specifies whether this specification should be ignored if another specification was handled before as |
priority | undefined | number | ContentSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is handled |
propertyCategories | undefined | PropertyCategorySpecification[] | ContentSpecificationBase | Specifications for custom categories. |
propertyOverrides | undefined | PropertySpecification[] | ContentSpecificationBase | Specifications for various property overrides that allow customizing property display. |
relatedInstances | undefined | RelatedInstanceSpecification[] | ContentSpecificationBase | Specifications of related instances that can be used when creating the content. |
relatedProperties | undefined | RelatedPropertiesSpecification[] | ContentSpecificationBase | Specifications of related properties which are |
showImages | undefined | boolean | ContentSpecificationBase | Should image IDs be calculated for the returned instances. |
Defined in
- presentation/common/src/presentation-common/rules/content/ContentRelatedInstancesSpecification.ts Line 18
Last Updated: 20 June, 2023