ContentInstancesOfSpecificClassesSpecification Interface
This specification creates content for all instances of specific ECClasses.
see Content instances of specific classes specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
classes | MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] | Defines a set of multi schema classes that specify which | |
excludedClasses | MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] | Defines a set of multi schema classes that prevents specified | |
handleInstancesPolymorphically | undefined | boolean | Tells whether selecting instances from ECClasses specified in ContentInstancesOfSpecificClassesSpecification.classes and ContentInstancesOfSpecificClassesSpecification.excludedClasses | Deprecated |
handlePropertiesPolymorphically | undefined | boolean | Specifies whether properties of derived ContentInstancesOfSpecificClassesSpecification.classes should be included in the content. | |
instanceFilter | undefined | string | Specifies an ECExpression for filtering instances | |
specType | "ContentInstancesOfSpecificClasses" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties | undefined | CalculatedPropertiesSpecification[] | ContentSpecificationBase | Specifications of calculated properties whose values are |
onlyIfNotHandled | undefined | boolean | ContentSpecificationBase | Specifies whether this specification should be ignored if another specification was handled before as |
priority | undefined | number | ContentSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is handled |
propertyCategories | undefined | PropertyCategorySpecification[] | ContentSpecificationBase | Specifications for custom categories. |
propertyOverrides | undefined | PropertySpecification[] | ContentSpecificationBase | Specifications for various property overrides that allow customizing property display. |
relatedInstances | undefined | RelatedInstanceSpecification[] | ContentSpecificationBase | Specifications of related instances that can be used when creating the content. |
relatedProperties | undefined | RelatedPropertiesSpecification[] | ContentSpecificationBase | Specifications of related properties which are |
showImages | undefined | boolean | ContentSpecificationBase | Should image IDs be calculated for the returned instances. |
Defined in
Last Updated: 20 June, 2023