CheckBoxRule Interface
Deprecated in 3.x. Use ExtendedDataRule instead. See extended data usage page for more details.
CheckBox rules provide a way to create a checkbox for specific types of ECInstance's.
see CheckBox rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | undefined | string | Defines a condition for the rule, which needs to be met in order to execute it. | |
defaultValue | undefined | boolean | Default value to use for the check box state | |
isEnabled | string | boolean | Indicates whether check box is enabled or disabled. | |
propertyName | undefined | string | Name of boolean type ECProperty which is bound with the check box state. | |
ruleType | "CheckBox" | Used for serializing to JSON. | |
useInversedPropertyValue | undefined | boolean | Should property value be inversed for the check box state. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 20 June, 2023