constructor Method
Creates an instance of NestedContentField.
NestedContentField(category: CategoryDescription, name: string, label: string, description: TypeDescription, isReadonly: boolean, priority: number, contentClassInfo: ClassInfo, pathToPrimaryClass: RelationshipPath, nestedFields: Field[], editor?: EditorDescription, autoExpand?: boolean, renderer?: RendererDescription): NestedContentField
Parameter | Type | Description |
---|---|---|
category | CategoryDescription | Category information |
name | string | Unique name |
label | string | Display label |
description | TypeDescription | |
isReadonly | boolean | Are values in this field read-only |
priority | number | Priority of the field |
contentClassInfo | ClassInfo | Information about an ECClass whose properties are nested inside this field |
pathToPrimaryClass | RelationshipPath | Relationship path to Primary class |
nestedFields | Field[] | Contained nested fields |
editor | EditorDescription | Property editor used to edit values of this field |
autoExpand | boolean | Flag specifying whether field should be expanded |
renderer | RendererDescription | Property renderer used to render values of this field |
Returns - NestedContentField
Defined in
Last Updated: 20 June, 2023