LinearlyLocatedSingleAt Interface
Beta
Interface to optionally be implemented by Elements inherently Linearly-Located whose linear-locations are always a single at-position. It also provides convenient APIs for callers to reach Linear-Referencing data stored on aspects. Classes implementing this interface should make use of the services provided by LinearlyLocated.
Extends
Methods
Name | Description | |
---|---|---|
getAtLocation(): undefined | LinearlyReferencedAtLocation | ||
updateAtLocation(linearLocation: LinearlyReferencedAtLocationProps, aspectId?: string): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getLinearElementId(): undefined | string | LinearlyLocatedBase |
Defined in
Last Updated: 20 June, 2023