insertFromTo MethodStatic

Insert a new LinearlyLocated element into an iModel at a specific from-to location along an existing Linear-Element.

insertFromTo(iModel: IModelDb, elProps: ElementProps, linearElementId: string, fromToPosition: LinearlyReferencedFromToLocationProps): string

throws IModelError if unable to insert the element.

Parameter Type Description
iModel IModelDb The iModel to insert the new element into.
elProps ElementProps The properties of the new element.
linearElementId string The Id of the Linear-Element along which the new LinearlyLocated will be inserted.
fromToPosition LinearlyReferencedFromToLocationProps Linear position.

Returns - string

The newly inserted element's Id.

Defined in

Last Updated: 20 June, 2023