insertAt MethodStatic
Insert a new LinearlyLocated element into an iModel at a specific location along an existing Linear-Element.
insertAt(iModel: IModelDb, elProps: ElementProps, linearElementId: string, atPosition: LinearlyReferencedAtLocationProps): string
throws IModelError if unable to insert the element.
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel to insert the new element into. |
elProps | ElementProps | The properties of the new element. |
linearElementId | string | The Id of the Linear-Element along which the new LinearlyLocated will be inserted. |
atPosition | LinearlyReferencedAtLocationProps | Linear position. |
Returns - string
The newly inserted element's Id.
Defined in
Last Updated: 20 June, 2023