getAtLocation MethodStatic
Query for the single LinearlyReferenced AtLocation aspect owned by the specified LinearlyLocated Element. If more than one aspect is expected, use LinearlyLocated.getAtLocations instead.
getAtLocation(iModel: IModelDb, linearlyLocatedElementId: string): undefined | LinearlyReferencedAtLocation
throws IModelError
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel to query from. |
linearlyLocatedElementId | string | The id of the LinearlyLocated Element to query about. |
Returns - undefined | LinearlyReferencedAtLocation
Returns an LinearlyReferencedAtLocation or undefined is none is found.
Defined in
Last Updated: 20 June, 2023