getAtLocations MethodStatic
Query for LinearlyReferenced AtLocation aspects owned by the specified LinearlyLocated Element.
getAtLocations(iModel: IModelDb, linearlyLocatedElementId: string): LinearlyReferencedAtLocation[]
throws IModelError
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel to query from. |
linearlyLocatedElementId | string | The id of the LinearlyLocated Element to query aspects about. |
Returns - LinearlyReferencedAtLocation[]
Returns an array of LinearlyReferencedAtLocation.
Defined in
Last Updated: 20 June, 2023