SnowParticle Interface
Beta
Represents one particle displayed by a SnowDecorator. Particle positions are in CoordSystem.View.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
velocity | Vector2d | Current velocity, in pixels per second. | |
x | number | Make x, y, and z from ParticleProps writable. | |
y | number | ||
z | number |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
rotationMatrix | undefined | Matrix3d | ParticleProps | A rotation matrix to orient the particle. |
size | number | Readonly<WritableXAndY> | ParticleProps | The size of the particle, in the collection's coordinate space. |
transparency | undefined | number | ParticleProps | The transparency with which to draw the particle as an integer in [0,255]. |
Defined in
Last Updated: 20 June, 2023