SnowDecorator Class
Beta
Simulates snowfall in a Viewport using particle effects.
see SnowEffect for a Tool that toggles this decorator.
see ParticleCollectionBuilder for defining custom particle effects.
Implements
Methods
Name | Description | |
---|---|---|
configure(params: Partial<SnowParams>): void | Change some of the parameters affecting this decorator. | |
decorate(context: DecorateContext): void | ||
toggle(viewport: Viewport, enable?: boolean): Promise<void> Static | Toggle this decorator for the specified viewport. |
Properties
Name | Type | Description | |
---|---|---|---|
dispose Readonly | VoidFunction | Invoked when this decorator is to be destroyed. | |
viewport Readonly | Viewport | The viewport being decorated. |
Defined in
Last Updated: 20 June, 2023