ParticleProps Interface
Describes a particle to to add to a particle collection via ParticleCollectionBuilder.addParticle. The x, y, and z coordinates represent the centroid of the particle quad in the collection's coordinate space.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
rotationMatrix | undefined | Matrix3d | A rotation matrix to orient the particle. | |
size | number | Readonly<WritableXAndY> | The size of the particle, in the collection's coordinate space. | |
transparency | undefined | number | The transparency with which to draw the particle as an integer in [0,255]. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
x Readonly | number | XYAndZ | x coordinate |
y Readonly | number | XYAndZ | y coordinate |
z Readonly | number | XYAndZ | z coordinate |
Defined in
Last Updated: 20 June, 2023