CustomAttributeContainerDiagnostic<ARGS extends any[]> Class
Beta
An IDiagnostic implementation used for CustomAttributeContainerProps diagnostics.
Extends
Methods
Name | Description | |
---|---|---|
constructor<ARGS extends any[]>(container: CustomAttributeContainerProps, messageArgs: ARGS, category: DiagnosticCategory = DiagnosticCategory.Error): CustomAttributeContainerDiagnostic<ARGS> | Initializes a new CustomAttributeContainerDiagnostic. |
Properties
Name | Type | Description | |
---|---|---|---|
diagnosticType Accessor ReadOnly | DiagnosticType | Gets the DiagnosticType. | |
schema Accessor ReadOnly | Schema | Gets the schema where the diagnostic originated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category | DiagnosticCategory | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | The diagnostic category is of the type DiagnosticCategory; which is defined as an enumeration above. |
code Accessor AbstractReadOnly | string | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | Gets the unique string identifier for the diagnostic in the format ' |
ecDefinition | CustomAttributeContainerProps | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | The EC object to associate with the diagnostic. |
undefined | ARGS | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | The arguments used when formatting the diagnostic message. | |
string | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | Gets the message associated with the diagnostic. |
Defined in
Last Updated: 20 June, 2023