onTransformElementAspect MethodProtected
Transform the specified sourceElementAspect into ElementAspectProps for the target iModel.
onTransformElementAspect(sourceElementAspect: ElementAspect, _targetElementId: string): ElementAspectProps
note A subclass can override this method to provide custom transform behavior.
Parameter | Type | Description |
---|---|---|
sourceElementAspect | ElementAspect | The ElementAspect from the source iModel to be transformed. |
_targetElementId | string | The ElementId of the target Element that will own the ElementAspects after transformation. |
Returns - ElementAspectProps
ElementAspectProps for the target iModel.
Defined in
- transformer/src/IModelTransformer.ts Line 1118
Last Updated: 20 June, 2023