constructor Method

Overloads
constructorTreeBranch(props)  
constructorTreeBranch(props, context) Deprecated  

TreeBranch(props)

TreeBranch(props: TreeBranchProps | Readonly<TreeBranchProps>): TreeBranch

Parameter Type Description
props TreeBranchProps | Readonly<TreeBranchProps>  

Returns - TreeBranch



TreeBranch(props, context)

Deprecated  

TreeBranch(props: TreeBranchProps, context: any): TreeBranch

see https://reactjs.org/docs/legacy-context.html

Parameter Type Description
props TreeBranchProps  
context any  

Returns - TreeBranch


Last Updated: 06 January, 2023