LoadingSpinner Class
A loading spinner component that optionally shows a text message.
Extends
- PureComponent<LoadingSpinnerProps>
Methods
Name | Description | |
---|---|---|
constructor(props: LoadingSpinnerProps | Readonly<LoadingSpinnerProps>): LoadingSpinner | ||
constructor(props: LoadingSpinnerProps, context: any): LoadingSpinner | Deprecated | |
render(): Element |
Properties
Name | Type | Description | |
---|---|---|---|
defaultProps Static | Partial<LoadingSpinnerProps> |
Defined in
Last Updated: 20 June, 2023