LoadingPrompt Class
A component to display during loading that optionally shows percentage, status text and a cancel button.
Extends
- PureComponent<LoadingPromptProps>
Methods
Name | Description | |
---|---|---|
constructor(props: LoadingPromptProps | Readonly<LoadingPromptProps>): LoadingPrompt | ||
constructor(props: LoadingPromptProps, context: any): LoadingPrompt | Deprecated | |
render(): Element |
Properties
Name | Type | Description | |
---|---|---|---|
defaultProps Static | Partial<LoadingPromptProps> |
Defined in
Last Updated: 20 June, 2023