LoadingPromptProps Interface
Properties for LoadingPrompt component
Extends
Methods
Name |
Description |
|
onCancel(): void Optional |
Function called when Cancel button is clicked. |
|
Properties
Name |
Type |
Description |
|
isDeterminate |
boolean |
Determine if a percentage bar is displayed (isDeterminate=true), otherwise a loading spinner or indeterminate progress bar is shown. |
|
message |
undefined | string |
Message displayed below the title (optional) |
|
percent |
number |
Current percentage. |
|
showCancel |
boolean |
Show cancel button. |
|
showIndeterminateBar |
boolean |
Show indeterminate progress bar instead of loading spinner |
|
showPercentage |
boolean |
Show percentage at the end of the loading bar (optional). |
|
showStatus |
boolean |
Show current status and percentage. |
|
status |
string |
Current loading status text (optional). |
|
title |
string |
Title |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023