Dialog
Components for working with a Dialog or MessageBox.
Classes
Name | Description | |
---|---|---|
Dialog | Dialog React component with optional resizing and dragging functionality | |
GlobalDialog | GlobalDialog React component used to display a Dialog on the top of screen | |
Message Box React component. | ||
Message Container React component. |
Enumerations
Name | Description | |
---|---|---|
DialogAlignment | Enum for dialog alignment | |
DialogButtonStyle | Enum for button style. | Deprecated |
DialogButtonType | Enum for button types. | Deprecated |
Message Severity enum. | Deprecated |
Interfaces
Name | Description | |
---|---|---|
DialogButtonDef | Interface for a dialog button in a button cluster | Deprecated |
DialogProps | Properties for the Dialog component | |
GlobalDialogProps | Properties for the GlobalDialog component | |
GlobalDialogState | State properties for the GlobalDialog component | |
Properties for the MessageBox component | ||
Properties for the MessageContainer component |
Last Updated: 20 June, 2023