Triangulator Class
(static) methods for triangulating polygons
- @internal
Methods
Name | Description | |
---|---|---|
constructor(): Triangulator | ||
computeInCircleDeterminantIsStrongPositive(nodeA: ): boolean Static | * nodeA is a given node | |
createFaceLoopFromCoordinates(graph: , data: LineStringDataVariant, returnPositiveAreaLoop: boolean, markExterior: boolean): undefined | Static | create a circular doubly linked list of internal and external nodes from polygon points in the specified winding order | |
createFaceLoopFromCoordinatesAndMasks(graph: , data: LineStringDataVariant, returnPositiveAreaLoop: boolean, maskForBothSides: , maskForOtherSide: ): undefined | Static | create a circular doubly linked list of internal and external nodes from polygon points. | |
createTriangulatedGraphFromLoops(loops: GrowableXYZArray[] | Readonly<WritableXAndY>[][]): undefined | Static | * Only one outer loop permitted. | |
createTriangulatedGraphFromPoints(points: Point3d[]): undefined | Static | Create a graph with a triangulation points. | |
createTriangulatedGraphFromSingleLoop(data: GrowableXYZArray | Readonly<WritableXAndY>[]): undefined | Static | Triangulate the polygon made up of by a series of points. | |
directCreateChainsFromCoordinates(graph: , data: MultiLineStringDataVariant, id: number = 0): [] Static | Create chains from coordinates. | |
directCreateFaceLoopFromCoordinates(graph: , data: LineStringDataVariant): undefined | Static | Create a loop from coordinates. | |
flipTriangles(graph: ): number Static | * Visit each node of the graph array | |
flipTrianglesInEdgeSet(graph: , edgeSet: ): number Static | * Visit each node of the graph array | |
triangulateAllPositiveAreaFaces(graph: ): boolean Static | Triangulate all positive area faces of a graph. | |
triangulateSingleMonotoneFace(graph: , start: ): boolean Static | Triangulate a single face with (linear time) logic applicable only if the lowNode is the lowest node. |
Defined in
- topology/Triangulation.ts Line 40
Last Updated: 20 June, 2023