InsertAndRetriangulateContext Class
Context for repeated insertion of new points in a graph.
- Initial graph should have clean outer boundary. (e.g. as typically marked with HalfEdgeMask.EXTERIOR)
- After each insertion, the current "position" within the graph is remembered so that each subsequent insertion can reuse that position as start for walking to the new point.
Methods
Name | Description | |
---|---|---|
insertAndRetriangulate(xyz: Point3d, newZWins: boolean): boolean | ||
moveToPoint(movingPosition: HalfEdgePositionDetail, xyz: Point3d, announcer?: (position: HalfEdgePositionDetail) => boolean): boolean | ||
reset(): void | Reset the "current" position to unknown state. | |
resetSearch(xyz: Point3d, maxDim: number): void | ||
searchForNearestEdgeOrVertex(xyz: Point3d): HalfEdgePositionDetail | Linear search through the graph | |
searchForNearestVertex(xyz: Point3d): HalfEdgePositionDetail | ||
create(graph: ): InsertAndRetriangulateContext Static | Create a new context referencing the graph. |
Properties
Name | Type | Description | |
---|---|---|---|
currentPosition Accessor ReadOnly | HalfEdgePositionDetail | Return a (reference to!) the current position in the graph | |
graph Accessor ReadOnly | Query the (pointer to) the graph in the context. |
Defined in
Last Updated: 20 June, 2023