projectedParameterRange Method
Project instance geometry (via dispatch) onto the given ray, and return the extreme fractional parameters of projection.
projectedParameterRange(ray: Ray3d | Vector3d, lowHigh?: Range1d): undefined | Range1d
Parameter | Type | Description |
---|---|---|
ray | Ray3d | Vector3d | ray onto which the instance is projected. A Vector3d is treated as a Ray3d with zero origin. |
lowHigh | Range1d | optional receiver for output |
Returns - undefined | Range1d
range of fractional projection parameters onto the ray, where 0.0 is start of the ray and 1.0 is the end of the ray.
Defined in
- curve/LineString3d.ts Line 1387
Last Updated: 20 June, 2023