projectedParameterRange Method
Project instance geometry (via dispatch) onto the given ray, and return the extreme fractional parameters of projection.
projectedParameterRange(_ray: Ray3d | Vector3d, _lowHigh?: Range1d): undefined | Range1d
Parameter | Type | Description |
---|---|---|
_ray | Ray3d | Vector3d | |
_lowHigh | Range1d |
Returns - undefined | Range1d
range of fractional projection parameters onto the ray, where 0.0 is start of the ray and 1.0 is the end of the ray.
Defined in
- curve/CurvePrimitive.ts Line 750
Last Updated: 20 June, 2023