UVSurfaceOps Class
Support methods to act on surfaces with 0..1 uv fractional parameterization
Methods
Name | Description | |
---|---|---|
createLinestringOnUVLine(surface: UVSurface, u0: number, v0: number, u1: number, v1: number, numEdge: number, saveUV: boolean = false, saveFraction: boolean = false): LineString3d Static | * evaluate numEdge+1 points at surface uv parameters interpolated between (u0,v0) and (u1,v1) |
|
sampledRangeOfOffsetEllipsoidPatch(patch: EllipsoidPatch, offsetDistance: undefined | number, options?: StrokeOptions): Range3d Static | Return the range of sampled points at specified offset from the surface. | |
sampledRangeOfOffsetPatch(patch: UVSurface, offsetDistance: undefined | number, numU: number, numV: number): Range3d Static | Return the range of sampled points at specified offset from the surface. |
Defined in
- geometry3d/UVSurfaceOps.ts Line 21
Last Updated: 20 June, 2023