hasIntersectionWithRay Method
Test if there is any intersection with a ray defined by origin and direction.
- Optionally record the range (null or otherwise) in caller-allocated result.
- If the ray is unbounded inside the clip, result can contain positive or negative "Geometry.hugeCoordinate" values
- If no result is provide, there are no object allocations.
hasIntersectionWithRay(ray: Ray3d, result?: Range1d, tolerance: number = Geometry.smallMetricDistance): boolean
Parameter | Type | Description |
---|---|---|
ray | Ray3d | |
result | Range1d | optional Range1d to receive parameters along the ray. |
tolerance | number |
Returns - boolean
Defined in
- clipping/ConvexClipPlaneSet.ts Line 268
Last Updated: 20 June, 2023